More PHP Customization in LiteSpeed Web Server 4.2.7

January 24th, 2014 by PHP , Web Server 2 Comments

In addition to improved ModSecurity and SSI, LiteSpeed Web Server 4.2.7 features more customization options for PHP in different settings.

The most important addition to LSWS 4.2.7 is probably support of the PP_CUSTOM_PHP_INI environment variable. This environment variable allows for custom php.ini’s in Plesk with PHP-FPM. Before, Plesk users had to switch to LSAPI if they wanted custom php.ini files (though we still recommend LSAPI as faster than PHP-FPM).

In addition, LSWS 4.2.7 enables use of the $VH_USER variable in environment variables. This variable refers to the virtual host’s user and can be used to create further per-user customizations.

These are just small steps compared to the big changes coming with LSWS 5.0. The first RC for 5.0 should be out in a matter of days, bringing SPDY/3.1 and WebSocket support to Enterprise. (They’re already supported by OpenLiteSpeed.)

We’re always looking to improve. Let us know if there are any features you want to see!


Tags:
Posted in:PHP , Web Server

Related Posts


Comments